Robots could not resolve host address

dash-dns
dash-crypto
#1

Hello all,

I have set up CloudFlare for one of my domains that is hosted on a VDS. When I activate CloudFlare, robots of Facebook, Twitter, GTMetrix cannot fetch required information for them. When I debug this situation with Facebook URL Degubber and Twiter Card Validator, they all give errors such as “Couldn’t resolve host address”.

My DNS configuration is below.

Any help is appreciated.

#2

The IP and domain seems to be wrong…:slight_smile: Do you have any firewall rules setup?

1 Like
#3

My guess would be the OP posted a sample screenshot with similar settings, but then thats just a guess :).

@yenerunver, can you post the actual settings? Redact IP addresses if necessary.

1 Like
#4

While it would be nice to have 1.1.1.1 and 123.123.123.123 and example.com, t
hat was my first guess too. :grin:

#5

This is the actual settings :grinning: I just changed the domain name to example.com and IP address to 123.123.123.123 from element inspection in developer tools before taking the screenshot.

#7

Kinda hard to diagnose mechanical problems with a car by emailing the mechanic a picture… :slight_smile:

1 Like
#8
#10

I have disabled the CloudFlare temporarily until I fix the configuration

#11

Do you want me to enable it again?

#13

I enabled it again. We do not have additional firewall rules, besides the standard rules of Plesk panel.

#14

Now it is all broken. Gives “too many redirects” error.

#15

What is your SSL mode set to? Looks like it may be set to Flexible. If you have a certificate on your server (which you should!), switch it to Full and see if this fixes the issue.

1 Like
#16

@domjh thank you man, setting SSL setting to Full solved the problem.

1 Like
#17

No problem! If it is a valid certificate on your server, you should also be able to increase it to Full (strict), increasing the security further :slightly_smiling_face:

1 Like
#18

Will do, thanks for the tip.

1 Like
closed #19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.