Response Time 6-7 sec after SSL enabled


I have an SSL enabled CF site. (SSL status Full, Edge certificate created.) Before making changes, response time was around <1 second. But now after typing the site name and press enter in any browser, we have to wait 6-7 seconds to see the homepage.

What would be the reason?


There could be many reasons, would you mind sharing the domain name?

How are you doing the redirects? Page Rules/UI or server-side? The delay seems to be the first page rendering.

Adding the link to a test:

I have not used any page rules yet. I am doing the redirects from CF user interface only.

Well, the to is quick (I suspect cached by Cloudflare), but the replies with redirect from to the HTTPS version and the reply to the HTTPS take a while. I think you should add a page rule for the initial redirect (which are in the user interface) and then enable the Always Use HTTPS toggle in the SSL/TLS app.

I expect the issue is some problem in the rendering of the Wordpress server. Can’t help you there unfortunately. Maybe @sdayman can.

Page rule is added. Always use https toggle is now ON. But I think no changes.

There was a big change, confirming my suspicions.

Two things:

  1. you need to remove the redirect from to server side since it is removing HTTPS.
  2. the server is taking extremely long to reply, optimize Wordpress.

Look at the new waterfall here, you’ll see all the redirects and the delay in the HTML:

Since the site doesn’t require visitors to log in, I would suggest two things:

  1. Use a Page Caching plugin like W3TC. Personally, I use WP Fastest Cache since it’s efficient.
  2. Use Cloudflare Workers to intelligently cache your site:
    Improving HTML Time to First Byte
1 Like

Thank you. How can we test wp fastest cache plugin to understand whether it works?

This topic was automatically closed after 30 days. New replies are no longer allowed.