Response caching problems with long loading pages



I have a domain on cloudflare ; a part of it (a directory) is clearly marked in page rules as “cache level : bypass”. But some pages in it (bash processings needing lots of time - like 1 to 2 hours - and lots of debug display) seem to stall at a certain point, and the page content stops loading.
Since it’s most probably due to long processing stalling the response, i tried to flush foo data (simply space characters), but it doesn’t seem to work.

I never had this kind of problems before using cloudflare, so i suppose it’s due to cloudlfare servers saying “ok, bored to wait, shut connection”. Is there a way to avoid this problem ?



I’m surprised this has worked for you before. Cloudflare doesn’t hold connections open for…hours. Here’s another thread on the subject:


As i told, those scripts didn’t run through cloudflare before.
Well, i did mark the script so that it doesn’t stop on user_abort, but it was far from perfect.
I think i found a solution by creating a sub-domain which does not go through cloudflare. I will confirm or invalidate this theory in the next two days.


Sorry, I misread: “I never had this kind of problems before using cloudflare” as before while using Cloudflare.



Passing my long scripts via a subdomain that does not go through cloudflare solved the problem : it’s still long, but the connection stays open.
Problem solved, thanks.

closed #6

This topic was automatically closed after 14 days. New replies are no longer allowed.