Respect Existing Headers option missing for Edge Cache TTL

Is there a way to make the Edge Cache TTL respect the existing Cache-Control header from the website? I do not see an option to “Respect Existing Headers”.

I’ve setup the Cache-Control header to return the following:

cache-control: public, max-age=0, s-maxage=60

The intent is to have no caching in the browser (for html) and only use edge caching. Is there a different configuration option that would achieve the desired behavior?

Note:
I scoured through the previous posts and have not found an answer for anything current.

Opened a ticket with the Support Team and looks like that option was removed for some reason, not disclosed in the ticket. I was however able to achieve the desired behavior using a few different options.

  1. Ensure no cookies are returned by the origin server as part of the response. If your website returns a cookie then cf-cache-status will always return BYPASS.
  2. Configure page rules
    a. Cache Level : Cache Everything
    b. Origin Cache Control : On

Now reviewing in Chrome DevTools you can see the cached output.

image

image

This topic was automatically closed after 30 days. New replies are no longer allowed.