[Resolved] Setup non redirect subdomain to https

Hi here,
I want to setup for a custom domain a non redirection to HTTP (this subdomain is an alias of go.mailjet.com)

I have tested many rules in page rules but nothing is working :confused:

Thanks for advance,
Jeff

Can you post exactly what you want to redirect from where to where?

Thanks for your answer Sandro,

I want to redirect https://go.mydomain.com to http://go.mydomain.com.

You basically just want to redirect from HTTPS to HTTP, correct?

That would be a page rule then.

Yes, I don’t want to have an automatic redirect from http to https (actually this is the case)

I add these rules but this is not currently working :confused:

(I have replaced my domain by mydomain)

You just need to disable the “Always use HTTPS” option. Respectively, simply set the SSL mode to “Off”.

Yes, I have already disabled the option “Always use HTTPS”.
I set up “SSL Mode” to off (like my capture); but when I go to https://go.mydomain.com, there is not redirection to http://go.mydomain.com :confused: (Maybe I write a bad rules -> you can show my rules in my previous screenshot)

For starters, what is your domain.

My domain is livequestion.com with the subdomain go.livequestion.com

Your record does not appear to be proxied, you need to switch it to :orange: for page rules to work.

Even if my subdomain is an alias of another domain ? (It is a CNAME record)

Definitely.

Now it is working, thank you very much ! :slight_smile:

This topic was automatically closed after 30 days. New replies are no longer allowed.