Resolution with Dig not providing answers and not seeing proxy IP

I imported a new zone on Cloudflare, and I ran a Dig query against the Cloudflare nameserver. However, I don’t get any resolution results for my host. I am able to get an address resolution when I use NSlookup pointed at the Cloudflare nameserver, but that too is not providing the resolution I expected. I’m getting my Origin IP address rather than a Cloudflare proxy IP address. My A record is configured for the “DNS and HTTP proxy (CDN)” with the Orange cloud enabled. Shouldn’t this be resolving to a proxied IP address? And, why is Dig not providing an answer?

This is a new Business Tier account that is not yet in production. So, the registrar for my domain has not been configured yet for the Cloudflare nameservers.

Do you mean just clarifying some points?
What is the site that you are trying to configure?
What is the command that you ran for dig and for nslookup?
What do you mean your domain has not been configured for the Cloudflare nameserver? You can not use any cloudflare service is your domain is not using have their assigned Cloudflare nameservers.

To provide clarification based on your questions, I have a single zone configured (santaclaraca.gov) and I’m trying to test the resolution of the A record for “business.santaclaraca.gov”.
The methods I am using are NSlookup from the command line and Dig from an online website.

nslookup business.santaclaraca.gov adam.ns.cloudflare.com
Dig from www.geektools.com/digtool.php
My domain registrar has not been changed to point to Cloudflare servers for authoritative DNS. They are still pointing to our current DNS provider. So, the Cloudflare servers are still in test mode for our DNS resolution. The two tests that I ran (nslookup and Dig) are able to perform lookups on a designated nameserver, and I designated the lookups to be from a cloudflare nameserver.

:wave: @glandau,

Cloudflare will not proxy records until the zone is active. Dig appears to work for resolution. Once you have changed the nameservers Cloudflare will return the :orange: value.

dig business.santaclaraca.gov @ian.ns.cloudflare.com +short
38.99.114.16

-OG

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.