Requests to subdomain on a TLS-connected server never make it to the server

I have a server set up to connect to Cloudflare via TLS. I can connect just fine through the main domain name. (

I tried to set up a subdomain by adding a CNAME record that points “” to “”. It is configured like this:


I can ping and it works, but if I try to access, this request never makes it to my server. It is stopped at the Cloudflare layer. What am I doing wrong?

It does make it to the server, but it doesn’t get content and only a 404. This is something you need to fix on the server.

I would suggest you pause Cloudflare and talk to your host to make sure everything loads as desired on HTTPS. Once everything works, it will also work on Cloudflare.

@sandro , I did this. The host is sitting under my desk with the local network hostname “piguy”. http://piguy and http://highhands.piguy both work as expected. My server listens on port 8080, so I ran sudo tcpdump -i any port 8080 -n to monitor traffic and I see traffic from Cloudflare when accessing the main site, but no traffic when accessing the subdomain. At this point, if we assume Cloudflare is properly forwarding traffic, there might be some setting on the TLS setup I might be missing?

It currently is not paused.

Also, port 8080 does not work with TLS on Cloudflare, only these do → Network ports · Cloudflare Fundamentals docs

1 Like

Hold on, that doesn’t match what I am seeing. My server is definitely listening on 8080, I’m able to see the main site through Cloudflare, and with tcpdmp, I also see the TLS daemon forwarding traffic to 8080 like it is configured to do.

Can you pause Cloudflare for starters?

OK it is paused. Now what?

Are you using Tunnel? That’s something you didn’t mention.

Yes, I am tunneling. I guess I thought that’s what TLS was.

That’s a whole different story then, I am afraid.

I would recommend to open a thread at #zero-trust:cloudflare-tunnel with all the details on your Tunnel configuration and possible log output.

1 Like

OK, thanks

This topic was automatically closed 20 minutes after the last reply. New replies are no longer allowed.