Requests taking more than ~20 seconds

I have an s3 bucket with some js files which are hosted using cloudflare DNS. Till yesterday the files were loading within milliseconds, but since then it’s taking around 20 seconds for a 500kb file. The traffic is proxied through cloudflare and caching is set to standard. Even the cache HITs are having the same issue. Any suggestions how to debug and resolve this?

How have you tested this? I’d try something like this:

Yes, I have and the issue seems to be only in Asia. Other places are fine.

Which Cloudflare PoP are you reaching?

Navigate to https://www.cloudflare.com/cdn-cgi/trace in your browser (replace cloudflare.com with your domain)

It could be an issue with your ISP and connectivity to that data center

1 Like

I navigate to the above mentioned URL and it gave the following response:

visit_scheme=https
uag=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.69 Safari/537.36
colo=LHR
http=http/2
loc=IN
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off

Does colo mean the data center location, if it is then it should be BLR. Should I contact my ISP?

[Update] I tried another domain which is hosted on cloudflare and it fetches from the closest data center. Is this expected?

Never mind, I took Cloudflare pro just to raise a support ticket and it started working.

Not a surprise. The higher you go in plan level, the more priority your domain gets in local data centers.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.