Report of Deprecated API Usage in Cloudflare's Auto-generated Script

Dear Cloudflare Support Team,

I hope this message finds you well. I am writing to report an issue related to a deprecated API usage that is originating from a script automatically generated by Cloudflare’s services.

Issue Description: In our Lighthouse performance report, we have received a warning for “Deprecated API Usage” in a specific script URL: cdn-cgi/challenge-platform/scripts/jsd/main.js. It is important to note that this script is not part of our website’s codebase, but rather appears to be automatically generated by Cloudflare.

Details:

  • URL with Deprecated API: /cdn-cgi/challenge-platform/scripts/jsd/main.js
  • Script Origin: Cloudflare (Auto-generated)

Impact: While this script is not under our direct control, the warning from Lighthouse affects our overall website performance score, and we are concerned about the potential impact on our users’ experience.

Request: We kindly request your assistance in addressing this issue. It would be greatly appreciated if you could investigate and, if necessary, update or modify the script in question to ensure that it no longer uses deprecated APIs. This would help us maintain a higher level of performance and ensure our website’s compliance with current web standards.

Possible Solutions:

  • Review the script’s code and identify any deprecated API usage.
  • Update the script to use modern and non-deprecated APIs.
  • Ensure that Cloudflare’s auto-generated scripts comply with the latest web standards.

Additional Information: If you require any additional information or access to our Lighthouse reports, please feel free to reach out to us. We are committed to working collaboratively with Cloudflare to resolve this issue in the best way possible.

Thank you for your prompt attention to this matter. We look forward to your assistance in resolving this issue and appreciate your ongoing support of our web services.

Sincerely,

1 Like

This has come up a time or two (or more) before:

https://community.cloudflare.com/search?q=deprecated%20script

How to remove that script(cdn-cgi/challenge-platform/scripts/jsd/main.js)? PLEASE !!!

How could I solve this? Thank you!!

Hi there,

Thanks for contacting Cloudflare community, sorry to read that you’re experiencing difficulties.

This script is added when you enable Bot fight mode (or Super bot fight mode) in your Cloudflare Security dashboard: → Bots → Configure (Super) Bot fight mode.

Please review the following documentation if you need to disable it:

I hope this information was useful, let us know if we can further assist you in this matter.

1 Like