"remove the proxy status for insideroutside.com to"

Okay so this may be a bit long since I am a bit of a noob.
"To the point>>> When I select edit with elementor on any of my blog posts of name
“best x for y” rather than loading my blog post Elementor editing tool with the blog post opening up, it opens a saved template that is currently live on my site. The page it opens is for a given group of “best x for y” item and no matter which blog post i open to edit with elementor it opens that same template… meaning no option to edit the actual post. In short I can’t edit a post because i can’t even acces it.
the link to my screencast is here:

I am told by siteground support the issue is 99% likely due in their opinion to my cloudflare as per the following:

remove the proxy status for insideroutside.com to

this is what i was instructed to ask of cloudflare support. I am hoping that either this gets passed on to them in addition to the ticket i submitted for further clarity, or, that someone here knows enough to help without adding new hurtles… lol thanks in advance.

If you have Rocket Loader enabled in the Speed -> Optimization section of the Cloudflare dashboard, disable that. Sometimes that helps.

i just checked it says its off

Had ELEMENTORS’ send me this as a fix or series of attempts to fix.
Some of them I understand others not so much. Somewhat generic and mostly vague but still at least they replied today.


Our main goal at Elementor is to create the fastest, most advanced page builder for WordPress.
To achieve this, we make sure it is based on the latest technology available.

Here are the system requirements you need in order to use Elementor.
(If you are not sure whether or not your server support this, contact your host).

WordPress 5.0 or Greater

Elementor works with WordPress version 5.0 or greater

PHP 7 or Greater

Note: If your site is hosted on a server with an older PHP, you may experience issues. We recommend you to contact your hosting provider to upgrade to the latest version of PHP .

Elementor may also work with PHP 5.4+, but these older versions have reached official End Of Life and as such may expose your site to security vulnerabilities and bugs, and may not always work as expected.

MySQL 5.6 or Greater

MySQL version 5.6 or greater OR MariaDB version 10.0 or greater

WP Memory Limit

WP Memory limit of 128 MB or greater (256 MB or higher is preferred)

For further reading check here


Please note that you must use Chrome, Firefox, Safari, or Microsoft Edge version 79 or greater to EDIT pages with Elementor. You will not be able to edit with versions of Microsoft Edge which are earlier than version 79, nor can you edit with any version of Microsoft Internet Explorer. Microsoft’s newest versions of Edge (v. 79 and higher, which was first released in January, 2020) are based on Chromium (the same base as Google Chrome), so Microsoft’s new Edge is now fully capable of editing pages with Elementor. Of course your pages built with Elementor will display as designed in all modern browsers. Most features will display properly in IE but because IE is an older browser, it is incapable of supporting some of the modern web technologies that Elementor may utilize for some of its features.


It is not possible to edit with mobile phones and tablets for the moment. You can only edit pages with Elementor on desktop computers.


If your website is hosted by WP Engine, you might need to add SSL to your website to avoid saving issues.

If you use SiteGround or GoDaddy, make sure that they modify the SubstituteMaxLineLength of your server for you: https://docs.elementor.com/article/219-502-error-when-i-try-to-edit-with-elementor

X-Frame options

It has to be set to “same origin” to avoid editing issues. Please ask your host to do this for you.

PHP Z-Lib Extension

It is preferable to have PHP Zlib extension enabled on your server. Please ask your host to enable this for you, if it is not.

Plan B:

Go to Cloudflare Dashboard’s Overview section for your domain and put it into Development Mode.

This topic was automatically closed after 31 days. New replies are no longer allowed.