Releasing kubectl support in Access


1 Like

Good article, although in my experience trying to get this to work in the recent months it has been somewhat a nightmare.

I first had issues when I realised the flags were missing in the latest release. EG.


I then found that the cloudflared access tcp command was not in the recent version.

Both have subsequently been resolved, although I’ve still been unsuccessful in getting this to work for my cluster. My support ticket has been running for almost a month ontop of the month I already lost trying to figure this out on my own.

Would love your feedback, perhaps could sync up and see if I’ve done something wrong somewhere.


1 Like

Hi @michaelfornaro,
I have had some problem too.

Somehow they disappeared after I changed the follow alias ( Documented in this page )

$ alias kubeone="env HTTPS_PROXY=socks5:// kubectl"


$ alias kubeone="env HTTP_PROXY=socks5:// kubectl"

This opened a webpage where I had to authenticate and authorize the client.

Before I got the error:

> kubeone get ns
Failed to connect to proxy URL: "http://socks5://"
Failed to connect to proxy URL: "http://socks5://"
Failed to connect to proxy URL: "http://socks5://"

But then I tried with the original alias and everything was working as expected. So therefore I do not know. May be some glitches from Cloudflare.
But now everything is working as expected.
Without any other details from your side is very difficult to help.

I solved this as I mentioned just above. I do still have a running issue with using cloudflared as a sidecar in my pod but to no avail so far.

I’m open to suggestions - here is the thread Argo Tunnel Kubernetes Sidecar Model

Managing the client, especially multiple clients at the same time was really painful for me, then I created this project to help me get rid of the amount of alias for kubectl, it might be helpful for you too!