Reissued certificate has wrong address

Earlier today my site was not accessible externally. Performing an ssl check my certificate was renewed yesterday but it seems with the wrong address. How can I rectify this?
Thanks

What error were you getting?

What address was it for? *.<your domain>?

Thanks for replying but managed to sole the problem following this from another post and the certificate now has the correct address.

  1. Navigate to the bottom of the SSL tab/page settings at Cloudflare dashboard
  2. Click on the button “Disable Universal SSL” and wait for a five minutes
  3. Click the same button again to Enable Universal SSL
  4. This method usually reset the process of generating Universal SSL certificate
2 Likes