Refused to connect


#1

Hello I’m new to using cloudflare. I think ssl is working with my domain because i used a ssl checker and it seems good. I have setup my .htaccess file and changed pretty much all links to use https and proxy links and messages but when i go to my website now it say refused to connect

here is my site: https://psychotic-hell.com/


#2

That error is coming directly from your origin server. At the moment your site is not using Cloudflare. The NS records don’t point to Cloudflare and your www and root resolve to the origin IP.

It appears also that your site is not listening on port 443.


#3

yeah thats because i gave up. Im trying again now have added the nameserver back again and opened port 443 but still isn’t working


#4

oh lol i think its fixed. all i had to do is add this to my xenforo confix.php

$_SERVER[‘HTTPS’] = ‘on’;


#5

I have one more problem. http isn’t redirecting to https even though i have it enabled in the setting on cloudflare


#6

nvm seems it was cache problem but speaking of that problem my current users they either get a connection refused or a white messy page if they dont clear their cache. its kinda hard to get them all to clear their cache