Redirecting http to https

Page Rules:

  1. nebulousgaming.com/*
  2. www.nebulousgaming.com/* - Always use https
  3. http://… - Always use https

SSL - Flexible
Edge Certificates - Active
Always Use HTTPS - ON

Tried all this and it has been more than 14hours but still i don’t see the redirect.

That domain is using Cloudflare’s name servers, but it doesn’t look like the DNS entries for those hostnames are set to :orange:. They need to be :orange: for Page Rules to work.

I also don’t get a DNS response for www.nebulousgaming.com. It also needs a DNS entry.

Thanks for your quick response Sdayman. Where can i find the DNS entry for http://www.nebulousgaming.com ?

Hi @user3617,

You can find this in the DNS app of your Cloudflare Dashboard.

Thanks again. I mean what entries i have to put there?

You could follow Redirect www.example.com to example.com if you want www.nebulousgaming.com to redirect to nebulousgaming.com, or you can add an A record that looks like:

But replace 192.0.2.1 with the same IP address in your other records, the one ending in .92.

As for redirecting HTTP to HTTPS, you can remove the page rules and just use the Always Use HTTPS setting you have

This is not working because currently your DNS is :grey:, when you go to the DNS tab, you will see a list of records. The A record with the name nebulousgaming.com currently seems to have a :grey: next to it, click that so it turns :orange:.

You should also be aware that this is not recommended or secure.

3 Likes

Thanks! Followed your above guide and now it’s working.
Only issue is that if i am changing SSL to Full the site is not working/responding anymore.

1 Like

No problem, glad that worked for you.

You need to get your web host to install an SSL certificate on your server so you can change that to Full (strict), you can get a free Cloudflare Origin Certificate, or one from Let’s Encrypt or another certificate authority.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.