Redirecting A record from 1 coludflare hosted domain to another gives me an error

I am trying to redirect a domain to another using A records. Both domains are at Cloudflare. This is giving me an error. Help please.

An A record can only point to an IP address, not to a domain. This is how DNS works, and not a limitation imposed by Cloudflare.

You could use CNAME instead.


I understand that. However, should it not work if I have the proper IP address for the domain?

I have used dns checker to get the IP address, but Cloudflare states it conflicts with its system.

Also, I am using Cname, but still have the same error.

Cloudflare’s IPs are dynamically assigned. Even without the error, there’s no guarantee that that IP address will always point to your domain.

Use CNAME instead for Cloudflare to automatically resolve the domain to the currently-assigned IP address. This is possible even for the apex (root) domain because Cloudflare supports CNAME flattening (aka ANAME).


Can you provide a screenshot of your DNS setting showing this CNAME setting and the error message?

I just CNAME’d one domain to another (both domains are active on Cloudflare) and I didn’t get any error.

It worked for half a day and then starting giving me the same error.

If you want to redirect you can use page rules:

If you want to point to the same origin, you should point to the same origin server as the other domain not it’s advertised Cloudflare Ip address.


I will check this out and let you know if I still have issues. Thanks

I have tried using page rules, but it does not seem to work assuming I set it up correctly. Here are 2 screenshots
Actually it is not letting me add screenshots

I guess it just took a while to work. It seems to be working fine now. Thank you for all your help.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.