Redirected to garbage site

To check the security of your connection, confirm the notifications

Checking the security of your connection to the site

Confirm that you are human

ConfidentialityConditions

First you need to confirm the security of your connection. When the pop-up appears, confirm the notifications.

2 Likes

It seems like you’re encountering a security check pop-up that is designed to confirm you are a human and not a bot. This is a standard procedure to protect websites from automated attacks. To proceed, simply follow the instructions on the pop-up to confirm the notifications. If you continue to experience issues, ensure your browser is up to date and consider clearing your cache or trying a different browser. If the problem persists, contact the website administrator for further assistance.

i am also getting same things on my website from last 7hour. first i though someone doing ddos, but it later i realize it was a bug. i tried deleting my domain from cloudflare and readding but facing same issue.

1 Like

@avilovel2014 what is your security level? Visible here, https://dash.cloudflare.com/?to=/:account/:zone/security/settings

Screenshot 2023-12-24 at 11.17.41 AM

Set on Security Level section

hii i think my website is hacked, can someone pls help me restore the website

illuminations.ae

1 Like

Is it redirecting to a site you do not recognize?

If so, go here, there is a rule causing that.
Screenshot 2023-12-24 at 11.28.39 AM

If you do not recognize the rule, you should delete it, change your password, rotate any API tokens and ideally enable 2FA.

The rule shows as being created by the account owner, but the IP used is different than the IP for other changes

Screenshot 2023-12-24 at 11.31.33 AM

Go here to see your audit log, https://dash.cloudflare.com/?to=/:account/audit-log

1 Like

Check your Audit Log for any recent changes.

If there were any changes made, remove the redirect (check Page Rules, Redirect Rules and Bulk Redirects) and secure your account:

2 Likes

@avilovel2014 @user87820 @sarawut-cub you each have a redirect rule that was added to your account. @sarawut-cub you will need to remove that rule on each of your affected websites.

Change passwords, rotate API tokens, enable 2FA. Let us know if you encounter any issues.

I did not check, but pretty sure this statement will hold true for each of the affected websites,

1 Like

only this was in my redirect rule.

1 Like

my domain redirecting me to garbage site and showing site under ddos attack

If you disable that rule, does your site behave as expected?

nope everything same. i have deleted my site cloudflare and readd and updated domain server with new one. but problem was same

1 Like

I only show your domain as having one set of cf nameservers.

If you deleted the site from your account then you should see if there have been any other changes that are causing the redirect to continue once cf is out of the picture.


Here is what I can see for each of the accounts affected on this thread.

  1. There is a redirect rule called WWW that is redirecting to a trash site.
  2. The above site is resolving to garbage site which appears to be a spoofed cloudflare captcha page.
2 Likes

i deleted my previous domain due to the same issue, then i add again with the nameserver provided by cloudflare. when i checked my site without and SSL still it going to same page

What is the name of the domain causing issues? Is SSL now enabled? Verify the contents of your DNS records as sometimes removing & re-adding a site can result in incorrect dns records.

this was my domain. i am using Cloudflare service from a year but never faced problem like this before

i tried putting ssl on flexible and off both but same issue

At the moment, nameservers seem to be propagating, scott & zainab are showing on whois and aldo & virginia (your current nameservers) on whatsmydns, DNS Propagation Checker - Global DNS Testing Tool

And, the redirect rule is in place, you should go here and disable that rule, https://dash.cloudflare.com/?to=/:account/:zone/rules/redirect-rules

And, ssl/tls is currently disabled. First thing, you should change your password as the setting I see are not what you’re sharing.

After that, change ssl/tls to Full (strict), follow instructions here Full (strict) - SSL/TLS encryption modes · Cloudflare SSL/TLS docs to put a free certificate on your server to support the setting, Origin CA certificates · Cloudflare SSL/TLS docs.

1 Like

Thanks, It doesn’t work, I have set both low and medium.