Redirect with query string not working

What is the name of the domain?

example.com

What is the issue you’re encountering

I created a redirect rule not to redirect when url contains example.com/customer. However, as soon as I add example.com/customer?id=123 it redirects.

What steps have you taken to resolve the issue?

Tried tracing the route. 1 result was successful (not via browser), using a different tool it gave me a 403 error.
Tried to turn off firewall settings, bot protection
Tried removing https:// from the url

The redirect works only as long as the url doesn’t contain anything else even though I specifically configured it to have ‘does not contain’.

This domain is not using Cloudflare.

It was an example, sorry for not making that clear

It asks for the domain for a reason and providing fake information is not very helpful :wink:

Anyhow, the following expression will apply to all requests not using this particular path, regardless of a query string or not.

(http.request.uri.path ne "/customer")

The domain is cellularisrael.com
I applied the expression but its not working. To refer back to the issue, when I use cellularisrael.com/customer it works the way intended, when I use /customer?id=123 it doesn’t. This is regardless of whatever expression I tried meaning does not contain, does not equal, etc.

It actually works with a query string → sitemeer.com/#85f1549df395a1ed74c4a9c3c65e6be5d343247f

However you seem not to redirect HTTP requests.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.