Redirect via Cloudflare.com appears not to work properly


#1

I went through the steps described here and - after contacting my provider procredo - ended up with the following situation:

Whatever I looked at n the dashboard showed me that “everything was OK” but unfortunately, it wasn’t. When I tried to call up our page with “swing-o-matic.de” the result is shown in the lower part of the above image.:

The “https://” at the beginning was added automatically, but unfortunately the connection to our page was not made.

To enable our users to contact our page again I “paused” the cloudflare-service for the time being. So, now you can connect to
swing-o-matic.de without problems. What do I still have to do to make the cloudflare service work?!?


#2

I see that the configuration seems fine, the doubt I have is that you enabled Always use HTTPS without actually having a certificate active, which can take up to 24h to be issued on the free plan.

I would recommend restarting Cloudflare’s service, setting the records to :grey: (or disable Always use HTTPS) and waiting for the certificate to be issued (the status is in the crypto tab).


#3

HTTPS shows a certificate from Tibit which is invalid for this domain.

Ist das SSL Zertifikat on Cloudflare schon ausgestellt? Den status kann man im Dashboard unter “Crypto” sehen. Wenn das schon aktiv ist, schau nach den SSL Einstellungen. In dieser Kombinatoion solltest du nur “Full” verwenden.
“Full (strict)” sorgt dafür, dass Cloudflare das Zertifikat auf deinem Server validiert. Ist es, wie auf deinem Server, ungültig gibt es ebenfalls einen Fehler.


#4

Yeah, that could be also the culprit, but still I don’t recall the Full (Strict) option being the default. I assumed it wasn’t changed.


#5

IIRC it isn’t. But I got myself did it when o started with Cloudflare Full? Strict! Security first! xD


#6

Well yeah, but the default is probably even Flexible, otherwise they would break most domains…


#7

This topic was automatically closed after 31 days. New replies are no longer allowed.