Redirect to site on cloudflare, port 80 is refusing to connect

I recently setup a site on cloudflare. I have another site which I want to redirect to this site. I setup a 301 redirect but I am getting a message that the site on cloudflare port 80 is refusing to connect. The redirect is not going through. What is happening? What should I do to sort this?

Can you give the sites you are redirecting from and to?

Yes, I am trying to redirect https://www.nettiebowiecbt.ie/
to https://www.northstartherapy.ie/
I setup a redirect rule about five mins ago which I was hoping would help.

It’s redirecting on my mobile phone now so maybe it just needs some time :slight_smile:

www.nettiebowiecbt.ie (not on Cloudflare) redirects on HTTP ok…

curl -I http://www.nettiebowiecbt.ie/
HTTP/1.1 301 Moved Permanently
Date: Fri, 07 Jun 2024 17:33:39 GMT
Server: Forwarding
Location: http://www.northstartherapy.ie/
Content-Type: text/html; charset=UTF-8

It looks like you are using your host’s forwarding, so as expected redirects from HTTPS doesn’t work as HTTPS isn’t provisioned.

curl -I https://www.nettiebowiecbt.ie/
curl: (7) Failed to connect to www.nettiebowiecbt.ie port 443 after 15 ms: Connection refused
1 Like

So maybe I should setup www.nettiebowiecbt.ie on cloudflare and do the redirect from there?

1 Like

Makes sense.

1 Like

Thank you

I have done that but its still not redirecting. Whatmydns redirect checker says it is. So maybe I just need to wait?

The www record needs to be proxied if you want the redirect on Cloudflare to take effect.
https://cf.sjr.org.uk/tools/check?a63496180a42413f87f430fd41c33ab8#dns

1 Like

I think I have done that but am now getting an HTTP error code 502. Still can’t get it to redirect. Check my cloudflare results here: https://cf.sjr.org.uk/tools/check?4a5ecc7ce2c64029a73c37d0c0c87788
Thanks for your help!

And whatsmydns redirect checker shows a 502 bad gateway https://www.whatsmydns.net/redirect-checker?q=www.nettiebowiecbt.ie

Can you check here if Universal SSL is enabled. If it isn’t, enable it. If it is, disable it, wait 2-3 minutes, then enable it again.
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates


Yes, it’s was already enabled


Here’s dns in cloudflare. I’m just thinking maybe there is something going on at Register365.

Did you do this?

The status is Universal certificate, active

Sorry, you’re saying I need to disable it then make it active again. Apologies. I will do that.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.