Redirect to a url with query strings

Hi, I’m setting redirect rules for my domain.

I have a problem with one, I set a rule in this way:

FROM url: bundle . mysite . com has to redirect to mysite . com/checkout/?add-to-cart=1234

But when I test it redirects me only to https://mysite.com/checkout/ without query strings.

Consider that I want a static query string, not dynamic.

Can someone help me to fix this?

Thank you very much

Are you using Redirects?

Did you check “Preserve query string”?

1 Like

Yea sure, but I think that checkbox preserves the input query string , not the output ones, and in fact the problem still remains…

Sorry, you are wanting to have a query string on the URL the user is redirected to?

Yes, exactly.

My input url is a 3rd party level (without query strings), I want the user to be redirect to an url that contains static query strings.

I see no issue.

Created a redirect rule to take /test_redirect and have static redirect to /test?redirect=working. Did exactly what it said on the brochure.

In this instance, if “preserve query string” is checked, the request query string will override the query string of the destination e.g /test_redirect?wont=work/test?wont=work

1 Like

Thank you for your answer.

For clarification, i’ll post my example:

I want that users that visit this url: https://bundle.energeticpalming.com are redirect to https://my.energeticpalming.com/checkout?add-to-cart=33627

My rule:

(http.host contains "bundle.energeticpalming.com")

but if you try it, it doesn’t work.

If you visit the final url, you find the correct cart at the checkout
if you visit the bundle url, you’ll find an empty cart.

Thank you very much

As I said previously

Uncheck “preserve query string” (or “Conserva stringa di query”.)

1 Like

Oh right it works!

Thank you very much

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.