Redirect sub-domain


I would like to redirect a sub-domain to an external URL when both someone type or

1 - I manage to figure out when someone type it redirects users to the correct website.

My question is, I having issues to make it work when user type, it does not redirects.It gives error “DNS_PROBE_FINISHED_NXDOMAIN

What should I do?

The CNAME you created is only valid for (exact match).

You will need to create another CNAME record for the address as well, using either the full name, or just in the Name field.

→ Since your screenshot shows the record to be Proxied (:orange:):

Cloudflare’s Universal SSL covers only one-level wildcard, and will work for like, but NOT, as that one goes one level more deep.

As such, you could be ending up with another obstacle, in your attempts to get to work perfectly.

It does however look like the platform you use have generated a certificate so that is also covered with them, but it may require you to set the Proxy status for the record Unproxied (:grey:) / DNS-only, to work properly.



@DarkDeviL thank you so much for the reply, however, I still facing problems. To be honest, I have low knowledge on this field, so if you don’t mind, could you please walk me through step by step?

I added the following entry but still not working.

If I’m looking from my end, it looks like you may have set it to Proxied (:orange:) now? :thinking:

From my end, that hostname does however works fine now, although when trying to access directly, it is currently redirecting visitors over to

That redirect is done in the same way as how you would do e.g. redirect from the naked domain ( to the www variant (```), or the opposite way around.

The redirect seems to come from the store vendor (e.g. according to the set up, the operator of, and not directly form neither Cloduflare, nor Cloudfront which is also behind Cloudflare in it’s current state (and which normally seems to use).

Both shop and are sending me to the same content from here.

Otherwise, can you elaborate on how you’re still facing problems, and/or how it is still not working?

Any error codes/messages, any screenshots of the issue you can share, or so?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.