Redirect Stopped Working

I am an amateur and I feel like I am missing something obvious here. Just bought my brand new .com domain through Cloudflare and I am just trying to redirect it to a free wixsite. I followed the instructions linked below for DNS Management and Bulk Redirects, and it worked beautifully last night! I changed nothing and it no longer works.

Here are my DNS records:

My Bulk Redirect is simply:
Source URL | Target URL | Status
vote4wickman.com/ | https://vote4wickman.wixsite.com/home | 301

When I tried it before as a Single Redirect, it didn’t work. This way did and now it doesn’t. What did I do wrong? Please feel free to criticize. Thanks!

I wasn’t sure if the IP address from the DNS management article was correct or just a place holder, but then the redirect worked. Am I supposed to use an IP address from Wix? If so, I am not sure what IP to use or how to find it.

If someone has a better way to redirect, I am all ears. Obviously, I am just trying to find an economical solution to use an easier URL. Thanks!

Your redirect is working ok…
https://cf.sjr.org.uk/tools/check?c5c7e0b6cfa84258ae4c6551c6f2f058#connection-server-https

If it’s not working for you, try clearing your browser cache or using incognito/private mode in case your browser has cached a problematic previous redirect you set up.

As you note, the alternative is just to point your domain directly at Wix rather than redirecting to your Wix hostname.

Instructions are here…

You may need to set the records pointing to Wix to “DNS only” if using this method.

This sounds promising, thanks! Incognito did not work and it did not work in Edge, even after clearing the cache. Frustrating. But, I confirmed it is working for others. And that is all that matters. I am open to others ideas for why I can’t see it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.