Redirect Rule Not Working Properly

Trying to redirect all paths on a subdomain ( to the root path ( Obviously I don’t want the root path to redirect as well. Just getting redirect loop errors in my browser for the root path. What am I doing wrong?

The rule you shared is causing the loop. You should forward from* to the destination of The rule you shared is introducing the loop.

Doesn’t work.

That rule is still directing users from to Do you want visitors to go from to

No. I’ve set up R3 hosting on with a file that is displayed on So any paths on this subdomain result in a 404. To remove those 404’s I want to redirect all paths on back to or in itself is out of the question.

Update: This is still an issue.

Your original rule was correct, and should work as intended. Please change the status code to something like 303, purge all cache after enabling it and see if it loops, If it does, check the headers to see whether all redirects are with status 303, or some other status code.

1 Like

Just tried that. Still not working. It works for the URL “*” with the asterix, but nothing else.

Do not use * with Redirect Rules, they only work as wildcard in Page Rules.

You should go back to your original rule.

I’ve just changed it back and now it’s in a redirect loop with 303 codes.


Do you have any other Redirect or Page Rules that might affect this hostname? How about Workers routes?

1 Like

Good catch - yes. I had a Workers Route and a Configuration Rule. Now removed. Also cleared cache. Still not working. Is it because I’m using R2 on this subdomain?

Sorry, but I’m not familiar with R2. If this has a special procedure to purge cache, then try purging the cache for the “/” path.

Done. Still not working.

Check all rules (Redirect, Transform, Configuration, Page Rules etc.) that may apply to this hostname or to any hostname, as well as any rules that apply to the account, such as Bulk Redirects. Keep in mind that the rule should work (I tested it on a free-plan domain), so something else is making this redirect run twice.

Can’t find anything. Would be nice if there was a way to see everything applying to one URL/hostname in one place.

Agree, but… there isn’t. There won’t be anytime soon. So, check all your settings that could force a redirect, and review any Workers code, if applicable.

1 Like

Still nothing. I’ll just point it to a third party hosting provider and use their tools to do it. Thank you for your help.

1 Like