Redirect page loop for wordpress installation

qpsychics.com has a redirect loop error. This error often leads to website downtime and has two common causes: an incorrect SSL setting or forced HTTPS redirects., review our guide on troubleshooting redirect loops.”

I tried removing the SSL certificate but with no luck. I’m not sure how to do the rest. Can anyone help walk me through this? The issue is only with the one wordpress installation, not the rest of the site. My hosting company suggested I start here.

Thank you!!

Greetings,

Thank you for asking.

I can see it too, but unfortunately it is caused by some WordPress plugin like Yoast SEO or similar due to the HTTP headers returned:
X-Redirect-By: WordPress

Before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Is your WordPresss admin configured to work over HTTPS (SSL)?

At your origin host/server or disabling Universal SSL at Cloudflare? :thinking:

It was working with current settings up until today. I have have been using cloudfare for years.

I do not have a SSL through my hosting company, just through Cloudfare, the free one (Generate a free TLS certificate signed by Cloudflare to install on your origin server.)

I paused Cloudfare, waited, and still not loading.

It was set to flexible, when changed to full it said it could not connect to host server.

:point_up: this is the issue here:

as far as you stated:

Which also is related because you don’t have SSL at your hosting, or your hosting does not work over HTTPS (port 443) and Cloudflare cannot connect over HTTPS (only HTTP):

So what settings does it need to have in order to work? I have cloudfare paused and it’s now saying “The connection has timed out”.

In terms to make sure your websites continues working over HTTPS while using Cloudflare, right?

Ideally yes, I would like to continue with cloudfare. This all started when I had images not showing for the wp installation. Images wold show when clicked, but stated that for example:

qpsychics.com/:239 Mixed Content: The page at 'https://qpsychics.com/shop/' was loaded over HTTPS, but requested an insecure image 'http://qpsychics.com/wp-content/uploads/2016/07/CV-300x434.jpg'. This request has been blocked; the content must be served over HTTPS.

Once I paused cloudfare this issue resolved. But, the back-end is still not loading even when paused. SO I’m guessing that’s not an CF issues then correct?

Right.

May I ask if the Automatic HTTPS Rewrites option enabled at Cloudflare dashboard → SSL/TLS → Edge Certificates? :thinking:

Okay.

OK,

CF SSL Option: Full
CF Advanced Actions: Cloudfare service enabled
SSL Certificate At Hosting Company: Created
CF Edge Certificates: Universal
CF Always Use HTTPS: On

Resulting Error: Error 521

Ray ID: 6e12471668f41064 • 2022-02-21 19:10:57 UTC

Web server is down

Thank you for feedback.

A self-signed SSL certificate or? :thinking:

Free, self-signed I’m assuming.

Okay, so my hosting company suggested I change the IP address of my site pointing in CF to another. I did, and waited a half hour like suggested. I was able to get into the back-end of my WP again with CF paused. However, once I enabled CF again, the issue came right back and I could no longer access the back-end with CF enabled.

Hosting company response: This is due to some settings you have in your Cloudflare account which we cannot check. Generally what you need is to stop all redirection from Cloudflare and only keep it as dns protection. This is the bet I can explain it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.