Redirect non-www to www

Hi all,

I am looking to redirect https://mydomain.com to https://www.mydomain.com

I have tried setting it up in page rules forwarding URL doing things like: https://mydomain.com/* to https://www.mydomain.com/$1

This creates an infinite loop it seems in what happens. It should be noted that I have subsites that I want to remain how they are.

Unfortunately the https://mydomain.com is a CNAME only run by someone else and I cannot have access - which is why I’m trying to do this.

Any thoughts?

Thats all covered at Redirect example.com to www.example.com

Whats the domain?

Thanks, that is exactly what I tried, I will retry now though. Franciscan.dev is what I am trying it on

My guess would be the second redirect comes straight from your server. Check there too.

Thanks, would that be in the .htaccess or wp-config file?

Yes, but could be anywhere, even in your server configuration.

Gotcha, that’s unfortunate but I will be hunting it down! Thank you

Assuming your server IP address ends in 201, it does appear as if the redirect originated from Wordpress

X-Redirect-By: WordPress

So, probably not even Apache, but directly in your Wordpress configuration.

Here is what I think the issue is with: I assume I can’t change the DOMAIN_CURRENT_SITE ?
/* Multisite /
define(‘WP_ALLOW_MULTISITE’, true);
define(‘WP_SITEURL’, ‘https://www.franciscan.dev’);
define(‘WP_HOME’, ‘https://www.franciscan.dev’);
define(‘DISALLOW_FILE_EDIT’, true);
define(‘MULTISITE’, true);
define(‘SUBDOMAIN_INSTALL’, true);
define(‘SITE_ID_CURRENT_SITE’, 1);
define(‘BLOG_ID_CURRENT_SITE’, 1);
define(‘DOMAIN_CURRENT_SITE’, ‘franciscan.dev’);
define(‘PATH_CURRENT_SITE’, ‘/’);
/
That’s all, stop editing! Happy blogging. /
/
* Absolute path to the WordPress directory. /
if ( !defined(‘ABSPATH’) )
define(‘ABSPATH’, dirname(FILE) . ‘/’);
/
* Sets up WordPress vars and included files. */
require_once(ABSPATH . ‘wp-settings.php’);

Its probably some setting in the database, but this is better clarified in a Wordpress forum than here.

1 Like

Makes sense, thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.