Redirect non-www to www by Page Rules

Hi, I’m trying to redirect all non-www traffic to www with Page Rules.
Here’s how my page rules look right now:
https://1stclub.xyz/*
Forwarding URL
https://www.1stclub.xyz/$1

I have Github page and my root domain has an A record for Github’s DNS records, and I also have CNAME www for 1stclub.xyz. Problem is that when I enable page rules, I get redirected too many times error, when trying to reach 1stclub.xyz?

For starters, make sure your encryption mode is Full Strict.

Then, can you post a screenshot of your page rule and the list of page rules?

The page rule is disabled.

Yes, because when it’s enable it gives the redirected too many times error, currently my website works fine.

Well, did you fix the encryption mode?

My encryption is now Full strict.

That’s good, you now have a secure site.

Ok, what about the page rule

As mentioned, it is disabled.

However there’s a 526, which suggests you have a security issue on your server and your host needs to fix the certificate. Pause Cloudflare and contact your host to get this fixed

Once the site loads fine on HTTPS, you can unpause.

Yes, because when it’s enabled it gives too many times redirected error, how can I fix this?

You need to fix the certificate issue for that. So pause Cloudflare and proceed as explained.

Oh now it says Invalid SSL certificate when enabled

Right, as I said.

So, how do I put this Cloudflare SSL Certificate to my site?

I do not think your host supports custom certificates but I understand they will automatically deploy a Let’s Encrypt one. Either use a search engine or contact them to ask how to enable SSL for your domain. That needs to work on HTTPS before you use Cloudflare.

I use Oracle Cloud’s VPS which is a ubuntu server

Did you not say Github? If you host it yourself, you need to consult your webserver manual for that.

Sorry I mixed things, yes I use github for my webpage.