Redirect loop on admin

Hello.

I just took over a website, and I happened to deactivate “Flexible SSL Cloudflare Loop Fix” or some ■■■■ like that.

Of course within a second I am completely locked out of my admin dashboard. I have tried turning cloudflare off and other suggested fixes but it doesn’t do ■■■■■■■ anything.

Any help would be greatly appreciated as I need to make edits to this website, but not possible if I cant log into the admin panel.

-Charles

The best thing you can do right now it go to the Overview page for that domain and click “Pause Cloudflare on Site” and wait five minutes to take effect.

Then you should get some access to admin to take care of what you need to take care of.

Make sure you get that site properly configured and running with HTTPS before you un-pause Cloudflare and then use Full (Strict) SSL mode. Then we can all stop cursing at Flexible SSL.

EDIT: You may have to untangle that site’s config for the canonical URL. This might help:

1 Like

Ok… I cant believe cloudflare can cause so many issues.

I was literally in the process of disabling it to just get my SSL through host (Cloudways).

Cloudflare offers many ways users can shoot themselves in both feet. Flexible SSL just means it’s done with a shotgun.

2 Likes

^Yea, exactly why I was trying to be done with cloudflare for this website.

The waiting 5 minutes did not work.

What does it mean by

“This is not necessarily the best fix, it’s just hard-coding the values into the site itself. You won’t be able to edit them on the General settings page anymore when using this method.”

in regard to changing site URL… can I just remove this code after I fix it?

Whats up.

I have the redirect loop error on my admin dashboard, due to deactivating a plugin “Cloudlfare Redirect Loop Fix” or something along those lines.

I have tried:

  • switching to full / strict / off

-disabling force redirect to HTTPS

-pausing cloudlfare

-clearing all cookies

  • refreshibng / editing my .htaccess file

-defining my sitename as http through wp-config.php

-creating a mu-plugins folder and uploading the plugin in said folder

-editing my wp-options.php table “active_plugins” to include said plugin.

Literally nothing is working and I need to make edits to my website. This whole problem happened because I was trying to leave cloudflare and get SSL from my host.

Can I just change my nameservers back to my domain providers nameservers??? Will this essentially cut off cloudflare completely and not have this redirect problem?

I have spent a stupid amount of time on this, just need to edit this website.

Thanks,
Charles

This topic was automatically closed after 14 days. New replies are no longer allowed.