Redirect issues after redirect setup

Hey all.

I have a domain: https://citizencosmos.space on Cloudflare and a redirect set up.

The domain should be redirecting everything to https://citizenweb3.com, but i can see that a lot of things arent getting redirected. What am i doing wrong?

Here is an example: https://citizencosmos.space/dilanasatekin its suppose to go to same link after / but to citizenweb3

Did you set the redirect as a page rule or redirect rule?

As redirect rules are now preferred (Page rules will be deprecated at some point), then copy this example, just change the host names (and delete the page rule if that’s what you used)…

2 Likes

Thanks for the help!

I tried doing all of this, broke all redirects completely. Went back to page rules. Seems to semi work as before. It seems im doing it wrong completely. Im setting up the expressions, etc as shown, but the redirects simply stop working when i go to redirect rules, rather than page rules.

Switch off the page rule for now. Set up a redirect rule as in the linked example, then show a screenshot of the rule you set if it doesn’t work.

Done. I have 3 page redirect rules (was going to buy more, but trying to get my head around these first) - all off and redirect rules - both on - citizencosmos.space aint redirecting as a result

Sorry, here is a screenshot of the second one:

First one, remove https:// from the value (look at the e.g. underneath for the format) and change from AND to OR (since the hostname can’t be www.example.com AND example.com at the same time).

You then don’t need the second one as the first one will act for both http and https.

1 Like

Thanks for your help!

I changed the first one and removed the second rule altogether, but the redirect does not seem to work still =(

The redirect is happening, the target of the redirect citizenweb3.com is not responding. You can see the steps here…
https://cf.sjr.org.uk/tools/check?a6809d49cf0848ce9466ccdd4c70db21#connection-server

That’s an issue separate from the (now working) redirect you need to check out.

www.citizenweb3.com does work. So either redirect to that or you need a redirect from citizenweb3.com to www.citizenweb3.com - but that site is not on Cloudflare so you’ll need to do that at the host for that site.

Now im fully confused…

citizenweb3.com is working and redirect has always been setup

Over that link it says: The checks did not complete as we found some problems with your configuration to use Cloudflare for citizencosmos.space. Help is available at…

And, about citizencosmos.space it says:
There was no response from the server within 15 seconds. The server is not responding or responds too slowly.

Im pretty certain the issue is the htpps, when i query https://citizenweb3.com/ - it seems to be dead. Sorry full lost here =(

Name dot com shows that its on, but its not…

Ignore those messages, it’s just saying that the process doesn’t complete to end in a 200 message. The problem is connecting to citizenweb3.com.

It seems https://citizenweb3.com isn’t working (timeout), but http://citizenweb3.com does (and redirects to www). That’s all done on your current host so you need to check there to fix that.

Well. It seems that name.com really has some issues with redirects and with 301, etc - so i just transferred the citizenweb3 domain to cloudflare too. Seems i can achieve more by having both of them on the same registrar +cloudflare seems more efficient and there are more possibilities.

Then I did this redirect rule:

And its still not working =)

Considering its all on cloudflare now. Im lost again =)

The redirect is working…

curl -I http://citizenweb3.com
HTTP/1.1 301 Moved Permanently
Date: Wed, 24 Jan 2024 17:27:26 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Wed, 24 Jan 2024 18:27:26 GMT
Location: https://citizenweb3.com/
Report-To: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=hbDD1x5I28Jiimbua4t7LkxSroyxwu3zOggX%2FqRi3%2Fq4kfvuyNWHjoSaqrtqoSxbuhGXrylqUIsPcmg7XCRweXuG9DsGdKT%2B9J%2FN6bwwxsvCjSorI8oac54P5EHWj8SzgKxfPgzWDspgiCqf01o%3D"}],"group":"cf-nel","max_age":604800}
NEL: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
Server: cloudflare
CF-RAY: 84a9fcb84fe579af-LHR

…but you may be better just to turn on “Always use HTTPS” instead.

There’s two issues…

  1. Make sure your SSL/TLS is set to “Full (strict)” here…
    https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

  2. Cloudflare hasn’t generated the edge SSL certificate yet. That should happen any moment, but can take up to 24 hours.

Things are a bit fluid at the moment with your setup as the change to nameservers propagates across the internet so just wait for everything to settle.

2 Likes

So going to summarize this. As of now the redirects still arent working. I can see the curl returning an answer, yet if i simply go to a clean browser on a clean device, almost everything returns with a timeout. Currently thats:

  • https://www.citizencosmos.space/
  • https://citizenweb3.com/
  • Some pages on citizencosmos with / after the . just do not redirect and return timeouts

What I have so far:

  • both domains in one place - Cloudflare
  • citizencosmos has a redirect rule setup to citizenweb as described here: Redirect issues after redirect setup - #9 by citizenweb3
  • There is also 2 page rules setup, as they are necessary to redirect the /rss feed directly - otherwise there is no redirects from the rss feed
  • citizenweb3 has strict ssl and always use https

The goal is to redirect all that is citizencosmos to citizenweb3, but as of now (i can see the curl results) I tried 2-3 devices, with clean history and as stated above - its returning timeouts. I asked several people to test it - same result =(

Any suggestions to make it work? Thanks a lot

You should try to fix one thing after another.

As @sjr explained in one of his previous posts, citizenweb3.com is not configured on your webserver, but www.citizenweb3.com is.

Moving the domain over to Cloudflare does not change anything, as this is a hosting problem, not a DNS problem.

Are you ok with using www.citizenweb3.com or do you want to use citizenweb3.com?

1 Like

Thanks for the reply.

Seems im not understanding something completely about the configuration of the webserver…

Im fine with using both I guess. Whats important to me is that people who type the www or dont type it still get to the same place.

Can you please explain to me how I configure this to work?

Then simply change the redirects to the version with www instead.

1 Like

So its not possible to have both at the same time? I thought the way it was configured works for both of them now

It’s generally bad to have the same content available under different names. It’s possible, but that would require you to fix the server configuration first.

1 Like