Redirect issue with websites

Hi! I have created rule to redirect one website to another (both have Cloudflare nameservers now) and unfortunately it has’nt worked so far. Please help me.

I am trying to do 302 temorary redirect and the response I get on the page is DNS_PROBE_FINISHED_NXDOMAIN

Have you created it using Cloudflare’s Redirect Rules, or through something that reside on your own server?

If the one website (let’s say is supposed to redirect to another (let’s say, have you actually created any DNS record(s) for would need a DNS record in your settings, in order to be able to resolve to any IP addresses, and for the public to be able to access it.

If you are attempting to do this using Cloudflare’s Redirect Rules, you can add a Proxied (:orange:) AAAA record for that, pointing to “100::”, which would likely be the solution to the issue you see.

1 Like

Hi Thank you, Yes I used Cloudflare redirect rules.
I already have for my .com website dns record for AAA.
Should I enter into IPV6 field: “100::” ?

Is that already existing “.com website dns record” you refer to, on the domain you want to redirect FROM, or the one you want to redirect TO?

And, for the site you want to redirect TO, - is that one already working as expected?


100::” is a standardized dummy / discard IPv6 address, which is the perfect for a set up, where you do not need the (sub)domain to point to any servers for other kind traffic, but still require functionality from Cloudflare, such as the Cloudflare Redirect Rules.

But that record is for use on the source (sub)domain (e.g. the one you want to redirect FROM).


I accidentaly changed AAAA of the .com website that the .ee is pointed to. How I can change it back ? Which one it was before ?

Now the .ee website that I want to redirect has AAAA dns record that’s IPV6 is 100::.
But it is still not working, maybe will take time.
Also, do I need to add other DNS record types?

Delete the current, and add the old one back.

We unfortunately cannot help you with that part.

But you can head to your Audit Log, which can maybe lead you on the right track.

If you’re looking for an action “Rec del”, and expand them, you might find the right (previous) record under the “Old Value”. If you see:

  "Comment": null,
  "Content": "",
  "Id": "[...]",
  "Name": "",
  "Proxied": true,
  "Tags": {},
  "Ttl": 1,
  "Type": "A",
  "Zone id": "[...]",
  "Zone name": ""

It would mean you should add “” (ref.“Name”) back, as an A (ref. “Type”) record pointing to (ref. “Content”).

For modified records (rather than deleted), you would simply look for the action “Rec set” instead, which should provide you with both “Old Value” and “New Value”.

Is the record Proxied (:orange:)?

And can you elaborate on “not working”, - what exactly do you see?

Not other than the one mentioned above, after having that Proxied (:orange:) AAAA record pointing to “100::”", the rest would be up to e.g. your Redirect Rules on Cloudflare, and whether or not that these have been configured as they should.

Is there any chance you could possibly share the list of DNS records for both the source and destination website, as well as the actual Redirect Rule you tried to set up?

If you prefer, the actual A/AAAA record(s) of your own server(s) can be partially redacted.