Redirect HTTP

When I open my website with http://(url) I get a SSL Handshake failed error but when I do http://www.(url) or https://www.(url) it loads perfectly fine, How do I make a redirect so http://(url) redirects to https, I have always use https on, Thank you, Domain: learnleapcenter.online

May I ask what steps for troubleshooting 525 error have you tried already from the article below? :thinking:

Furthermore, seems like non-www HTTP(S) version isn’t covered by the valid SSL certificate at your origin host/server, therefrom only www is, which is why Cloudflare determined by the SSL settings you’re using is trying to connect over HTTPS to your origin for non-www version results in an error for the end-user.

I’d consider double-checking below articles by following steps to make sure you’ve correctly setup the SSL for your domain while using Cloudflare:

Last but not least, kindly have a look here for more information regarding correct SSL settings:

Nevertheless, may I ask if you’re serving the same content on non-www and www version of your domain? :thinking:

If so, you could redirect non-www to www, therefrom making sure it’s working over HTTPS.

Here is the helpful article how to do it at Cloudflare dashboard by creating a rule:

1 Like

Example one shows you how do configure the redirect in Cloudflare. Your apex name will need to be :orange: proxied for the redirect to work.