Redirect http://www.eclectic-shop.co.uk/ to : http://eclecticantiques.co.uk/

Hi ,
I created page rule to redirect
http://www.eclectic-shop.co.uk/ to :
http://eclecticantiques.co.uk/

but it doesn’t work!
does anybody know why?
Many Thanks

It appears you have it set to forward www to www

curl -I https://www.eclectic-shop.co.uk/
HTTP/2 301
date: Wed, 17 Jul 2019 15:23:00 GMT
content-type: text/html
content-length: 191
set-cookie: __cfduid=d63d3a5654c862e8cb0f7ae131c327c661563376980; expires=Thu, 16-Jul-20 15:23:00 GMT; path=/; domain=.eclectic-shop.co.uk; HttpOnly
location: http://www.eclectic-shop.co.uk/
x-hrouter: hrouter4
cf-cache-status: HIT
age: 16
x-content-type-options: nosniff
expect-ct: max-age=604800, report-uri=“https://report-uri.Cloudflare.com/cdn-cgi/beacon/expect-ct
server: Cloudflare
cf-ray: 4f7d36ed4f15b38e-IAH

Oddly enough, HTTP seems to be configured differently. And HTTPS redirects to HTTP. This is unfortunate.

  1. Why are you redirecting HTTPS to HTTP? You have a working HTTPS certificate.
  2. Can you post a screenshot of your Page Rule?

Hi ,


what am i missing? thanks

Can you attach the image directly to your reply?

I can see that you have just the one Page Rule, but it’s not taking effect. http://eclectic-shop.co.uk/ redirects to http://www.eclectic-shop.co.uk/

Can you go to the DNS tab and scroll down a bit to confirm that the name servers are set to athena and darl instead of two other names?

Hi ,
I created page rule to redirect
http://www.eclectic-shop.co.uk/ to :

but it doesn’t work!
does anybody know why?
What am I missing ?
Many Thanks
Capture222|690x337


Hi S
do you mean that section above?
thanks

That would explain the problem. The Cloudflare account you added that page rule to is not the Cloudflare account that’s currently managing that domain. WHOIS says your domain is using the following name servers: Athena.ns.Cloudflare.com and darl.ns.Cloudflare.com

https://www.whatsmydns.net/#NS/eclectic-shop.co.uk


Hi again ,
so shall I replace the Value of the Cloudflare Nameservers from
adi.ns.Cloudflare.com
andy.ns.Cloudflare.com
To :
Athena.ns.Cloudflare.com
darl.ns.Cloudflare.com
?

and if so ,
how is that been done?
thanks


… and are the ! ! above ok?

thank you

Hi S ,
do you think it is going to work now ?

thanks a lot

This other account with your Page Rule doesn’t have the DNS records you need for that domain.

Since you’ve moved to a new domain, change that Page Rule to Match: *eclectic-shop.co.uk/*
And change the Forwarding URL to http://eclecticantiques.co.uk/$2

This way users trying www on your old domain will also be forwarded to the new domain, and the $2 means it will save the path from the old domain if anybody bookmarked it, or Google search has them.

Back to DNS. Add an “A” record for ‘@’ (no quotes) with an IP address of 192.0.2.1, and another “A” record for ‘www’ (no quotes) also with that IP address. This will make that site live with a Place Holder IP address that the Page Rule needs in order to work.

Thanks Sunshine - it works!

before I go , please when you can to have a look around my new website http://eclecticantiques.co.uk and let me know if it is listed , named or configurated correctly, with or without google, or anything else missing , that is not obvious to a beginner like me , ignorant enough to not be aware of it’s importance…

…and last I’m troubled , what is the meaning of [not secure] in the browser ,in the image i attached , and how possible to get rid of it…

Thanks again , and good evening
Dan

Not Secure is because it doesn’t have SSL enabled, which changes the URL to HTTPS. You will have to take care of this at your web host.

As of now, it appears that your original issue with your old domain’s Cloudflare configuration has been resolved. Anything regarding your new domain needs to be taken care of at your web host.

This topic was automatically closed after 14 days. New replies are no longer allowed.