Redirect errors when cloudflare active, none when paused

I had posted about this in another topic but someone closed it before it was resolved. Now have my site working fine in all respects but when I unpause Cloudflare I get re-direct errors when in www mode.

Running site diagnostics the only error of note is:

Check if redirecting unencrypted HTTP traffic works

Does the website redirect unencrypted traffic from HTTP to HTTPS?

but I do have force to https running within Cloudflare control panel.

When my site is running through Cloudflare I get redirect errors when the URL includes www.

When Cloudflare is paused, site resolves properly in all respects.

What’s the domain?

true / passage / dot / com

I have enabled Cloudflare on the site again now for you to have a look. whenever you add a www to the main site , or go to the siteurl/forums it will redirect error. The forums won’t work right unless they have the full https + www in the URL.

Well…that’s quite a mess. Best to take a step back with the “Pause Cloudflare on Site” option from the lower right corner of the overview page for your domain at dash.cloudflare.com

Give it five minutes to take effect, then be sure the site works as expected with HTTPS, www, /forums/, etc.

Cloudflare is paused now. You will note that the sites work fine now in all respects.

The only aspect missing is that it appears that I haven’t implemented a redirect to force everything to always have www, or at least that force redirect doesn’t seem to always work from all browsers.

Your site does function pretty well with Cloudflare paused. So…

  1. Make sure your SSL/TLS mode here is set to Full (Strict)
  2. Pick a canonical URL:

The tutorial below can help, but you just have to be darned sure your site is configured for the desired canonical URL.

When I went in there I noticed that there were already 3 rules (the max for a free Cloudflare account, it seems):

but the third rule was not enabled anyway, so I turned it off, and the rules then read as follows:


and after doing and re-enabling Cloudflare yes, everything force re-directed to www but then I still had all the redirect errors and the site would not load, at all! I tried both Full and Full Strict modes no difference, and I purged everything too a few times.

So, for whatever reason, the site just won’t function with Cloudflare engaged, and it used to work fine with Cloudflare for a couple years now. Not sure what happened recently that changed all that.

On this same server I have a different website that runs Cloudflare just fine, but this one isn’t working anymore.

Try turning all those rules off. They’re generally not necessary, and Rule #3 is particularly risky for a Forum, since you don’t want to cache other users’ logins.

That should clear up some of the issues and help narrow down if Rule #1 will work or not.

Maybe? I turned off both of those rules and Cloudflare is on now.

Take a look let me know if it is working for you too? It seems okay on some browsers but on Firefox it is trying to redirect to some really long URL and got a 522 timeout error.

That looks better. I use Firefox and don’t see any 522 errors.

Yes, I will check with vbulletin to see if any caching of the admincp is required, but for obvious reasons I am leaving those rules off!

Really appreciate your help here. I had started another thread on this issue several days ago, but the person who was helping me there Sandro kept insisting that the issues were only on the host side and closed the thread with no resolution without giving me a chance to post further.

The new error I am getting is a 522 if I try to access to site via an IPv6.

IPv4 on the exact same ISP works.

But as mentioned, I am running two different sites on Cloudflare, two different free Cloudflare accounts, but on the same server. The other one access fine exact same Ipv6 address.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.