Redirect error on the homepage / Umleitungsfehler der Startseite

Good evening,

After deactivating WP-Rocket (cache plugin), the homepage is no longer loading. Interestingly, the subpages are still accessible, such as https://www.koelner-musikakademie.de/grundschulen/.

Does anyone have an idea what could be causing this?

Thank you very much,
Asterios

My domain: https://www.koelner-musikakademie.de

Guten Abend,

nach dem ich WP-Rocket (cache Plugin) deaktiviert habe, wird die Startseite nicht mehr geladen.
Interessanterweise sind die Unterseiten weiterhin abrufbar, wie z.B. https://www.koelner-musikakademie.de/grundschulen/.

Hat jemand eine Idee, woran es liegen könnte?

Vielen Dank
Asterios

Meine Domain: https://www.koelner-musikakademie.de

I’m getting “too many redirects”…
https://cf.sjr.org.uk/tools/check?f6c64ae16ab24d9096fb0a2d9e6cdf1f#connection-server

Check your SSL/TLS settings are set to “Full (strict)” here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

Passing a path, there’s no redirect from HTTP…

curl -I http://www.koelner-musikakademie.de/grundschulen/
HTTP/1.1 200 OK
Date: Thu, 28 Dec 2023 19:08:41 GMT
Content-Type: text/html; charset=UTF-8
Connection: keep-alive
Link: <https://www.koelner-musikakademie.de/wp-json/>; rel="https://api.w.org/"
Link: <https://www.koelner-musikakademie.de/wp-json/wp/v2/pages/445>; rel="alternate"; type="application/json"
Link: <https://www.koelner-musikakademie.de/?p=445>; rel=shortlink
CF-Cache-Status: DYNAMIC
Report-To: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=LtZtD1EyK8UkcFdZkdcc1kQYbvGZl9aDcxasHU90M1voyiEfAaDqaCe2DmbkhMhzkgLTGEalaR6VtVGhupKNORZeblZs04WXk7%2FNU9QDawRt2TvlRLwYmiZGYsJuEGOO5GrIbDv2lWKWIlCnlet2"}],"group":"cf-nel","max_age":604800}
NEL: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
Server: cloudflare
CF-RAY: 83cc17e4ca1463f7-LHR
alt-svc: h3=":443"; ma=86400
1 Like

Thank you for the quick reply.

I already tested that and it made things worst. I get a 521 error.

Best
Asterios

Likely your origin web server isn’t allowing HTTPS and is actively rejecting connections to port 443. You would need to fix that.

(HTTP requests still work).

1 Like

Thank you so much again.

So, as I understand, I need to fix two things:

  1. http to https
  2. 443 port.

is this correct?

Yes.

  1. Fix on Cloudflare by enabling “Always use HTTPS” (after you’ve got #2 to work).
  2. Fix on your origin by making sure the web server there allows HTTPS connections on port 443 and has a valid SSL certificate.
1 Like

Oh ok!

I always had “always use https” activated…

I will check to see, if my provider allows the connections on port 443.

You likely had SSL/TLS set to “Flexible” before. This means regardless of if your users connect over HTTP or HTTPS to Cloudflare, Cloudflare connects to your origin over HTTP only.

This isn’t recommended as it deceives your users that the connection is secure end-to-end, when it isn’t. It is a legacy mode for when getting SSL certificates was expensive and HTTPS less commonly used. Now, with browsers forcing HTTPS to protect users, a better setup is needed.

For you it has shown up as your origin redirects requests to the home page to HTTPS (but not the other pages).

So a client connected to Cloudflare using HTTPS, Cloudflare connects to your origin on HTTP (when using “flexible” SSL/TLS), your origin redirects them to HTTPS, which makes the client go to Cloudlfare over HTTPS as before, then to your origin over HTTP, then redirecting to HTTPS, forever…

Using “Full (strict)” is needed to be secure. So get your origin to support HTTPS and then all will be good.

1 Like

Thank you again for everything.

You guided me to the right direction and I (hope) that the problems are gone now.
The SSL was not properly installed in my origin and that’s why I tried the “flexible” in Cloudflare.
It then worked and so I thought it’s fine.

But now I have contacted my provider and everything is set properly.

How can I thank you for your valuable help?

Best
Asterios

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.