Recently transferred to Cloudflare - cannot access my site

My site was working but I went into SSL - Edge settings. Before when I had a site with Cloudflare any url, www, http, https would connect as https. Mine always connected just as www. I tried changing the always use https and opportunistic on / off settings and thought I put them back but now I cant access my site www.constant-surfer.com at all

That domain is not currently using Cloudflare DNS or proxy services. It does not currently have a valid SSL certificate. Ask you host for assistance in setting this up.

Hi, I am a ‘new returner’ to Cloudflare. I used it a couple of years ago and thought it was great, especially the free SSL. I have recently added a site to Cloudflare after a couple of years of not using it. I can connect to my site using www or http or https which is a step forward but it seems to just redirect to www. I seem to remember last time I was using it I used to get the green padlock symbol and it showed as https:// am I doing something wrong can someone explain please - thanks guys

Most modern browsers, including Chrome, are lately slowly removing “secure” indicators, like the green padlock you’re talking about. The grey/white padlock you’re seeing now is expected and does not necessarily mean that your website is less secure.

If I access the site using www, http:// or http://www I get a grey padlock with a red line across it, if i try and access using https:// I get a message ‘The page isn’t redirecting properly’ I then cannot access the site at all unless I close and open the browser again.

I don’t have my origin server configured to redirect http to https (i wouldn’t know how to do that) as suggested in the community tip I have enabled the Always Use HTTPS feature in the Edge Certificates tab of the Cloudflare SSL/TLS website and now I can’t access my site at all

OK - sorted - Previously when I was a member of Cloudflare the standard SSL certificate issued was Flexible now the standard one issued is Full which apparently needs a self signed certificate installed on my server. So I have changed my ssl type to Flexible in the control panel and it all is working fine now. Would I be better changing it back to Full and taking the self signed certificate route - I am nervous since it is working ok and I dont want to do anything to mess things up especially If I discontinue Cloudflare, since I guess I would then have an unsupported SSL certificate installed on my server ?

This topic was automatically closed after 31 days. New replies are no longer allowed.