Recent change in WARP IP address behavior?

I have been using the WARP vpn with Zero Trust Access for several months without any issue. The Zero Trust Access policy has been setup to allow only my (locally assigned) external IP address. This has been working whether I was running the WARP vpn or not. Now, I can only access Zero Trust with WARP turned off.

So, is this the result of a recent change to the WARP vpn? In other words, did the WARP vpn until recently preserve my locally assigned IP address? If not, I can’t explain the new behavior.

Howdy,

I created this test policy:

Selector: Source IP
Operator: is
Value: 75.108.75.108 (my own IP)
[And]
Selector: SNI Domain
Operator: is
Value: telefonica.com

Action: Network Override
Override IP: 200.81.36.67
Override Port:

That’s a policy that, if the visitor IP is 75.108.75.108 (me), and I’m visiting the web https://telefonica.com then it’s gonna change the destination IP to 200.81.36.67 (which is telefonica.com.ar’s IP).

After creating that policy I waited a minute and tried to open https://telefonica.com and got a SSL certificate error because of the domain mismatch, which means the policy worked by recognizing my original IP. Then I changed the policy so the IP won’t match and tried again after a minute: The policy did not match, which means it worked.