Receiving "This link is not valid" attempting email verification

It appears that this has been occurring since February 2019. Has it ever been diagnosed or resolved for anyone?

I show emails as being delivered to you and have just resent a validation email as your account was not verified. I suspect that is the cause of the errors but lmk how it works out. Sorry for the pain.

Hello,

I received and followed the validation email. The interface then provided a reCAPTCHA asking me to identify boats, which I did, which then led to the standard:

1 Like

Can you clear cache & cookies and perhaps try incognito mode? I will resend a token. Sorry for the troubles

Just received another verification email (below). Same result.

Before I do it, the browser is set to block all third-party cookies in incognito mode – should I allow them?

yes, please allow them. I can kick off another token but will hold off until you have it set up, lmk

Okay – never mind. It worked in Incognito after clearing cookies (left the ‘block’ on).

Thank you for your help.

1 Like

I wrote a second ago – all is fixed (left it blocked).

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.