Received Cloudflare Email about Plugin Update

Hello,

I received the following email today telling me that I must update the Cloudflare plugin. I have two connected WordPress sites on separate installs. I don’t use or have the Cloudflare installed on either site. Am I required to install this plugin? I didn’t see any use for it or why it’s needed.


Dear Cloudflare Wordpress Plugin User,

We want to bring to your attention an essential update that will improve the security of your WordPress websites that utilize Cloudflare’s Automatic Platform Optimization and specifically the Cloudflare WordPress Plugin. It is highly recommended that you update to the latest version of the Cloudflare WordPress Plugin v4.12.3 at your earliest convenience.


The email is intended for users of the APO plugin. If you do not have the plugin installed on your WordPress sites, you are not required to install it.