Really Simple SSL failed to detect a valid SSL certificate. If you do have an SSL certificate, try to reload this page over https by clicking this button:


#1

I am getting this error after installing plugin on Wordpress.


#2

Do you have a valid SSL certificate on your server and your SSL mode in Cloudflare set to Full or Full (strict)?


#3

Hi,
Under the crypto tab, the universal ssl status says active certificate and the mode is set to flexible


#4

Ok, so that’s your SSL mode, do you (or can you) have an SSL certificate installed on the server with your host? You should if possible and this will probably solve this issue.


#5

I am using the free plan and trying to activate using Simple SSL plugin on wordpress. Wont I have to buy a certificate to install on server with host?


#6

You could install a Let’s Encrypt certificate that would be free and allow you to set the mode to Full (strict). This is much more secure. It would also solve that issue with the plugin which is presumably checking your server for a valid cert.

You could also install a free Cloudflare origin cert, this would also allow you to set the mode to Full (strict) but may not solve the issue with the plugin.

Alternatively, does your site load over HTTPS and have you tried clicking the reload page over HTTPS button?


#7

I have tried clicking the reload page (File not found ERROR 404) and have tried loading site over HTTPS (connection not private).
I might have to try installing a Let’s encrypt certificate now


#8

The plugin may work once the Cloudflare certificate is working, I don’t know how it checks for SSL.

This needs fixing first. What is your domain?


#9

#10

Your site loads OK for me over HTTPS, it just has a lot of mixed content (presumably why you are trying to get that plugin working).


#11

Oh. But while i have been trying to load https://www.whyshy.co , it does not load
I keep going to the connection not secure page


#12

Try clearing your cache - it works fine for me apart from mixed content.


#13

Hi, thanks a lot for your help. The page loads over HTTPS, but why is the secure symbol not appearing next to the search bar?


#14

That is due to the mixed content.


#15

Oh. Okay. Trying to rectify it. Thanks


#16

Hi sorry to bother you again, But i have turned on the Always Use HTTPS & Automatic HTTPS Rewrites in crypto settings, but it is still showing mixed content. How to completely secure the site?


#17

No problem. This is not something you can fix within Cloudflare,it has to be done on your actual site. Please see the guides below. There are also a lot of resources out there if you Google ‘mixed content’ and, in your case, ‘WordPress Mixed Content’


closed #18

This topic was automatically closed after 30 days. New replies are no longer allowed.