Re: Timezone format issue

Continuing the discussion from Hugo timezone format issue: (the original thread was already marked as ‘solved’)

While the solution is the following:

It only addressed the timezone “getting send twice”. The “MST value not being reported as it should” is only solved partially.

See the following examples (note: I set my TZ env to Asia/Manila)

The TZ workaround will only work if the TZ env matches the timezone language or offset. In the examples above, since the timezone for the Japanese and Korean pages is set (without offset) JA/KO lang (which is +0900), or (with offset set) +09:00, the “MST” value is still not being displayed correctly, it should be “JST” and “KST” respectively.

As we can see in these two “without offset” samples:

The system is capable of displaying the correct MST value.

As per @M4rt1n’s reply:

I assume that this issue is entirely Go related?


notes:

Can you reproduce the issue on your own server, or is it exclusively happening on Cloudflare Pages?

Yep.

On localhost, with my system set to Asia/Manila, the result is similar, only content on a different timezone doesn’t show the correct value for Go’s MST.

If there is no TZ env set:

  • in CF Pages: both +0800 and +0900 “MST” are not displayed
  • in GH Pages: both +0800 and +0900 “MST” are not displayed

I haven’t tested setting a TZ value in GH Pages (not sure how to do that over there) but I’m assuming the result will be similar since without a TZ env, CFP and GHP are the same.

But when I set TZ evn in CFP, it matched what I’m seeing in localhost. (Only those different from +0800 is not showing the correct Go MST value.)

Since locally reproducable this can not stem from Cloudflare Pages and therefore Cloudflares Devs can’t fix that, but indeed an issue inherited from golang itself.

I would recommend opening a ticket there, maybe even in the hugo community. The folks over there would probably also be happy to know about this, to keep an eye on.

EDIT:

just saw it: Bug?: MST showing as +0900 instead of the "MST" value - support - HUGO

Just so you know, the issue with sending the timezone offset twice happened, because there was no fallback provided by anyone. Not the function when called, nor the first callback, which is a global hugo cinfig, nor the second fallback, which would have been the host os. So here setting any TZ value (must be valid) would have fixed the issue.

1 Like

Got it. Thank you very much for the confirmation!.

Yep, currently tracking over at Hugo too but mysterious as well. However, based on your replies in both threads, it’s clearer now this is a GoLang issue. That itself is a huge help. Deeply appreciated!

Shalom!

You are welcome!

Shalom ve lehitraot :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.