RDP / Teams with Windows server using Argo stopped working - is there a new requirement?

Hi - I set up RDP access on two Windows machines for a small team using the new Cloudflare for Teams / Access tools. It’s been working perfectly for several months, but it all of a sudden stopped working on one of the machines today. My current setup is:

  1. Have my domain registered with CloudFlare
  2. Windows server runs cloudflared tunnel into rdp.site.com
  3. Access controls who can login
  4. Remote machine uses cloudflared to connect

The issue seems to be a failure in step #2. The Argo tunnel seems to be failing to connect. I updated cloudflared to the latest version and now it seems to be giving a new error. Specifically when I run this command which the service is running
cloudflared.exe tunnel --hostname rdp.site.com --url rdp://localhost:3389

I get an error saying “cloudflared does not support loading the system root certificate pool on Windows. Please use the --origin-ca-pool to specify it”

I have never had to specify this before and this error is not covered by the documentation here: https://developers.cloudflare.com/cloudflare-one/applications/non-HTTP/RDP

How do I fix this? I don’t know where to get the root certificate pool path… is this a new requirement? I did login to Cloudflare and get the access pem file per the documentation. I’m just trying to do the tunnel for the RDP connection nothing else and all the other settings I’ve left at the defaults. Would appreciate someone pointing me to any documentation I might have missed. Thanks!

Just saw Argo tunnel is having availability issues - please let me know if the issue could be related to that… will try again tomorrow morning.

Just want to close this out - everything is working now. Looks like Argo Tunnel had a temporary outage in the service. FYI the rdp documentation is correct and there is no need to load the Windows system certificates.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.