RDP becomes slow with warp

My RDP is lagging with warp turned on make it unusable. I am connected to private ip and route is enabled.

With warp turned off, connecting to public ip I get full speed

With warp turned on, connection to private ip

Speed is slow. What can we do

Connection to public ip with warp turned on gives good connection