Range header is ignore on large files

We’re encountering a strange issue when trying to download large files (700MB) from S3 with HTTP GET requests. If we use the ‘Range’ header, the behavior is inconsistent: the first request returns the entire file, the second only the specified range, and this pattern repeats. This doesn’t happen with smaller files. Is this a known problem? Is there a workaround?

This happens when files exceed the cache file size limit of 512MB but are set to be cacheable. You need to bypass the cache using a Cache Rule.

2 Likes

Is there a way to check if the range header exists in cache rules? I don’t see that as an option. Maybe I could check if it is empty?

You can check Request Headers in Cache Rules.

I can check there what its value is, but can I check whether it exists in the request headers?