Random 520 error

I just wanted to add this for everyone as it’s a real pain in the bum.

Some how Apache (Httpd) was installed along side my existing Nginx (even though I never had or installed or configured Apache).

After uninstalling Apache all issues went away.

UPDATE:

OK, the errors went away for a short time. Or maybe I did not test enough. I have 100% identified this issue to my additional security headers i am adding via nginx. These have been in place for over a year and only now have started causing issues. Below is the header attribute that was causing the pain.

add_header “Report-To:” "{“group”:“default”,“max_age”:31536000,“endpoints”:[{“url”:"https://twiliobilling.report-uri.com/a/d/g"}],“include_subdomains”:true}";

Hope that helps =)

Unfortunatly i’m running Plesk on a VPS - i can’t remove Apache and i don’t know why and how to solve this issues. The only way they go away is if i change CloudFlare proxy to DNS only on the DNS settings. If i proxy i got the error…
Can someone help?

Hi Net,

I just updated my answer. Please check to see if you are using any custom SSL related headers. The following header caused problems for me. Removed it, and no more errors.

add_header “Report-To:” "{“group”:“default”,“max_age”:31536000,“endpoints”:[{“url”:"https://twiliobilling.report-uri.com/a/d/g"}],“include_subdomains”:true}";

Hi again, it look like as the errors appear they are gone… for now!

I just hope they stay this way :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.