Railgun test fails with 301



I’ve set up Railgun successfully as specified by the CloudFlare documentation. The agent runs, I believe it is working, but when I press the “Test” button for my website in the CloudFlare “Speed” console, it comes back with: Error ‘Domain Name’, Railgun is not configured properly to accelerate ‘fqdn’ domain name.

Now the problem appears to be that the “Test” button calls -> https://www.mydomain.com and not https://mydomain.com.

We have our domain set up to CNAME www to just mydomain.com, thus the 301 redirect reported by the Railgun test tool. I believe the 301 redirect is what is confusing Railgun’s test, but I have no way to prove that as I have no idea why the “Test” is defaulting to https://www.mydomain.com.

I’ve combed over my configuration thoroughly and everything appears to be set to the shorter mydomain.com not www.mydomain.com

Anybody out there have suggestions?



This may or may not apply to your configuration. I just discovered that Railgun was failing for a few domains on my server. The issue was a page rule to “Cache Everything”. Disable this rule and the test result is Success. Enable the rule and the the test result is Error. I solved the issue by disabling that page rule, then performing a Purge Everything, then re-enabling that rule and performing the railgun test again which is now Success with the Cache Everything rule enabled.


I get a 301 result too but the test passes. Same here with my config is without the www yet the railgun test connects to www receiving a 301 result and 0 body length. I guess that’s good enough.