Railgun ‘railgun.supportedns.com’ is not configured properly to accelerate ..... Please make sure Railgun is configured properly

Hello

I have two issues with Railgun.

  1. I have TWO entries. Why is that? See screenshot : https://i.imgur.com/g1TtHvZ.png

  2. RAILGUN used to work for my website, but now it does not. This is the result of TEST Railgun:

Railgun test results for ‘railgun.supportedns.com

Railgun ‘railgun.supportedns.com’ is not configured properly to accelerate
learn-greek-online.com. Please make sure Railgun is configured properly.

Method: GET

url: https://www.example.com

Response status: 302 Found

location: https://example.com/

Protocol: HTTP/2.0

Elapsed time: 0.153933s

Body size (in bytes): 593 bytes

Body hash: a615465c75b2e50a4a967a76501ce1809f5d8a36

missing_headers: No Content-Length or Transfer-Encoding

Connection close: false

CF-Ray ID: 47d4a8d4d8a792d0-SJC

Cache status: EXPIRED

Location: 4 San Jose (SJC)

Cloudflare enabled: on

Railgun enabled: off

Isn’t there any supporter from CF to answer this?

From when I setup my Railgun, I asked CF support about the test button, they said it’s only testing against top level domain and to ignore test button results if you setup Railgun on a subdomain like you have. So don’t use test button to gauge if Railgun is working for subdomain setups. However, your subdomain isn’t matching http://railgun.supportedns.com/ vs http://learn-greek-online.com/ ??

Looks like you don’t have Railgun configured properly - check the docs at https://www.cloudflare.com/docs/railgun/

If non-toplevel domain is configured for CF Railgun, instead of test button use follow docs to find out if Railgun is working

I also wrote a shell script for my CentOS based server to gather Cloudflare Railgun stats and send them to my custom Slack channel to keep an eye on Railgun operation https://github.com/centminmod/railgun-stats

If you’re on Cloudflare Business plan, contact tech support. If you are using Cloudflare Railgun via a CF optimized hosting partner, then they should be the ones properly configuring CF Railgun for you.

Hope that helps.

1 Like

Hi

Thank you very much for the effort to help me.

I have a shared hosting plan with my webhost. I also have the FREE version of CF. I registered through CF, not through the webhost.

As far as I can see, there is nothing to setup for Railgun, either in the CF control panel, or on my webhost cpanel. My host and CF, they both said it is an issue that they have to solve. They had said this a year ago and it is still not solved.

I assume that http://railgun.supportedns.com/ is a server that belongs to my webhost, I have no access to it.

This topic was automatically closed after 31 days. New replies are no longer allowed.