QUIC not working

hello forum, even though i enable quic in cloudflare dashboard, when i check in http3check.net, it says bad status code from server. please help

Bad status code from server probably doesn’t mean it’s a QUIC problem. QUIC is most likely working.

I tested a handful of sites on Cloudflare and QUIC is working. What’s the domain?

1 Like

rafled.com

It passes this one:

but, it is still not showing as quic. is it a bug?

HTTP/3 includes QUIC.

https://www.litespeedtech.com/http3-faq

i know that but why doesnt quic work in my site even when i have enabled it?

Good question. Some of your site is, some isn’t. And I can’t see any reason they’re different. Including JPGs in the same directory. Maybe Support can figure it out.

Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.

1 Like

how did you see that?

Dev Tools in Firefox. Network tab.

1 Like

Is it weird that google and my site shows same cipher suite but my shows TLS 1.3 and google shows quic?

need to check with HTTP/3 quick draft the testing tool is testing for as current latest is h3-25 but some web servers are on h3-24 i.e. cloudflare and some are on h3-25 or h3-23 drafts

cloudflare HTTP/3 is on h3-24 draft support according to my curl-http3 built binary with cloudflare quiche HTTP/3 h3-24 library and also passes https://http3check.net

curl-http3 --http3 -Ivs https://servermanager.guide 


*   Trying 2606:4700:3035::681b:9406:443...
* Sent QUIC client Initial, ALPN: h3-24h3-23
* h3 [:method: HEAD]
* h3 [:path: /]
* h3 [:scheme: https]
* h3 [:authority: servermanager.guide]
* h3 [user-agent: curl/7.68.0-DEV]
* h3 [accept: */*]
* Using HTTP/3 Stream ID: 0 (easy handle 0x562c53bc8eb0)
> HEAD / HTTP/3
> Host: servermanager.guide
> user-agent: curl/7.68.0-DEV
> accept: */*
> 
< HTTP/3 200
HTTP/3 200

your domain gives 403 permission denied when I test it using curl-http3 HTTP/3 h3-24 tool

curl-http3 --http3 -Ivs https://rafled.com 
*   Trying 2606:4700:3036::681b:9b28:443...
* Sent QUIC client Initial, ALPN: h3-24h3-23
* h3 [:method: HEAD]
* h3 [:path: /]
* h3 [:scheme: https]
* h3 [:authority: rafled.com]
* h3 [user-agent: curl/7.68.0-DEV]
* h3 [accept: */*]
* Using HTTP/3 Stream ID: 0 (easy handle 0x5557f1299e80)
> HEAD / HTTP/3
> Host: rafled.com
> user-agent: curl/7.68.0-DEV
> accept: */*
> 
< HTTP/3 403
HTTP/3 403

Your 403 permission denied message probably interfering with http3check.net tester ?

That doesn’t explain why two JPGs give different results. Can’t check right now. Lots of CSP violations are preventing several resources from loading.

try now

It’s hanging up on waiting for Rocket Loader, but everything from your domain is now loading HTTP/3.

I ain’t have rocket launcher

It’s there. But the hangup is just in Firefox. Brave (Chrome) works better.

How do I disable rocket loader?

curl-http3 still shows 403 permission denied for me but canary 81 browser with h3-24 quic flag enabled shows quic for your pages loaded

image

By the way, I disabled the individual TLS 1.3 option. But I forgot where the rocket loader option was.