Quic does not work with CF

Hello

If I set dns to let the domain pass through cloudflare then quic doesn’t work. (h2)

alt-svc: h3-27=":443"; ma=86400, h3-25=":443"; ma=86400, h3-24=":443"; ma=86400, h3-23=":443"; ma=86400

However, if I change the dns settings to bypass CF, it starts working (http/2+quic/46)

alt-svc: quic=":443"; ma=2592000; v=“43,46”, h3-Q043=":443"; ma=2592000, h3-Q046=":443"; ma=2592000, h3-Q050=":443"; ma=2592000, h3-25=":443"; ma=2592000, h3-27=":443"; ma=2592000

I have enabled HTTP/3 (with QUIC) in CF settings

Something else needs to be set up for quic to work with CF?

1 Like

Domain?

https://shorturl.at/gM289

According to https://gf.dev/http3-test your site works just fine on HTTP 3. There are different flavours of HTTP 3/QUIC and Cloudflare might not support every available version but overall your site works fine on HTTP 3.

but when I look at the protocol in the browser, through CF every link I have h2 and if I turn off CF, each is h2/quic

For starters, QUIC is only relevant in an HTTP 3 context and not HTTP 2.

Your server might respond with different values, but the output you posted does refer to HTTP 3 and that automatically includes QUIC. As evident from the link, your site works fine on HTTP 3.

Sounds like your origin server might support QUIC i.e. if you use litespeed or h2o web servers. But Cloudflare doesn’t support QUIC, only HTTP/3 via h3-25 to h3-27 drafts

With support for HTTP 3 they implicitly support QUIC, as HTTP 3 is based on it

The origin might just support one of the revisions not supported by Cloudflare right now.

After HTTP 1.1 it all got a mess :smile:

FYI, HTTP/3 (over QUIC) via alt-svc h3-23 to h3-27 isn’t same thing as Google QUIC via alt-svc quic and h3-Qxxx

I didnt say it was. This is where the different revisions come in respectively Google’s original idea of QUIC.

The point I was trying to make is that HTTP 3 implicitly means QUIC. The version and revision mess is a different story.

1 Like

Yeah messy state in terms of terminology to differentiate everything :laughing:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.