Purging Cash - 520 Error

I purged cache for my site (www.https://ShopBote.com) via Cloudflare’s site settings (“Purge everything”) because I underwent a rename of my website (from SmallLocalBiz.comShopBote.com). However, it’s showing me a 520 Error when loading the page. I spoke with my hosting provider (BlueHost) while I was doing the rename and they said to contact CloudFlare for was to why I was receiving this error and how to fix it.

Here are the full details:

“There is an issue between Cloudflare’s cache and your origin web server. Cloudflare monitors for these errors and automatically investigates the cause. To help support the investigation, you can pull the corresponding error log from your web server and submit it to our support team. Please include the Ray ID (which is at the bottom of this error page). Additional troubleshooting resources.”

Cloudflare Ray ID: 6bd26a3168b57c7d
Output from: http://www.shopbote.com/cdn-cgi/trace

Please let me know how to fix this error!

Please help, your prompt assistance would be appreciated. Thank you

All I see is a NameCheap parked domain page:

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Hi Sdayman,
Thanks for your reply. I did as you suggested, “Pausing Cloudflare on Site”, but now the HTTPS isn’t working. It’s no longer a secure connection.

I used to have a fully built site, all I did was call BlueHost to change my domain to a new one. They said that CloudFlare’s having an issue with the cache, but I purged my cache, and it’s still not showing my site at the updated domain.

Could this have anything to do with the DNS records? I believe my DNS records might be pointing to BlueHost but it’s being hosted on Cloudflare?

If you paused Cloudflare, it should stay paused until you get things working with Bluehost. And that includes HTTPS. There’s nothing else to do here unless Bluehost finds that your DNS records are incorrect.

Hi Sdayman,

Thanks so much for the guidance. I paused Cloudflare on ShopBote.com, and per your recommendation, it’s staying paused until further notice. I also called BlueHost again and they said that I need to contact Cloudflare to update the “Nameservers” to


The A-Record was also updated to: (Bluehost told me to do this)

I see now that it has been paused, my website is back live! (although quite slow).

I feel like this process would have been way better if I just renamed my website via Cloudflare (if this is even possible).

Eventually, I will want to go back to using Cloudflare though because of its great CDN, speed & security. Is there a way to use Cloudflare while still keeping my website live after the renaming?

Your recommendations are much appreciated.

Daniel Shaby

I’m not sure if this helps, but I actually tried to connect Jetpack Backups to my new site’s credentials, even after Cloudflare was paused, and I was able to authenticate with the server but I got an error saying that they couldn’t find a WordPress installation through its publicly available URL.

A test file was uploaded, but Jetpack can’t access it over HTTP. This might mean the path is pointing to the wrong WordPress directory. [unreachable_path, 400]. I believe somehow the directory needs to be accessible.

Does this information help?

Sorry for the bother, fixing these issues mean a lot to me, and I hope to hear back soon.

Thank you,

I recommend that you get your site running 100% before putting it on Cloudflare. As of now, any issues need to be cleared up with Bluehost’s help.

Great, thanks Sdayman,
So I spoke with Jetpack & Bluehost, correctly identified the FTP credentials, and Jetpack has successfully been able to find the WordPress installation.

I believe that all that’s left is getting ShopBote.com back on CloudFlare, for its superior CDN, Security & Speed.

Would you be kind enough to help me with this?


The site loads properly for me. It should work with Cloudflare un-paused now.

I “enabled” Cloudflare back on ShopBote.com, but now it’s giving me an error, saying there are too many redirects and that my page isn’t functioning. But ShopBote.com doesn’t have any redirects. I only set up redirects for other domains through Cloudflare.

Any clues as to what might be going on?


Please make sure your SSL/TLS mode here is set to Full (Strict).

Thanks, Sdayman. The site is back up!

Should I enable the SSL/TLS Recommender?

As of this point, now that CloudFlare’s has been unpaused, I don’t need to replace my site’s Bluehost DNS records with CloudFlare or anything?

Much appreciated,

1 Like

You can enable the Recommender. I usually do.

No need to change anything else since the site is working now.

Got it, I enabled the Recommender.

Thanks for your help! Problem solved!


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.