Purging cache takes a very long time (15 mins+)


As of today, puring cache is taking much much longer than usual.

Using cache purge directly from the Cloudflare dashboard or through the API is taking 10-15 minutes, sometimes even more. Usually, purging the cache takes no more than a minute.

I wonder if this is related to the open issue “Configuration Settings Change Delays”.


Hi @janvitos,

I suspect it is related to this, once the status is marked as resolved, you could try again to see if the delay is still there.

1 Like

I will most certainly do that and report back here.


Yep…it’s happening to me, too. Both API and Dashboard Purge Cache isn’t happening…or taking a long time I’ve yet to see.

At first, it was taking a long time to purge, but now cache has not been purged in over an hour. I hope they fix this soon.

Adding to the fun, I’ve added a Page Rule to Bypass Cache, but whatever was cached is stuck in cache. Then again, if config changes are stuck or delayed, I’m out of luck for a bit. Not a catastrophe, but interesting.

I just saw on the Cloudflare status page that they have implemented a fix.

Monitoring - A fix has been implemented and we are monitoring the results.

But cache is still not purging for me.

Mine finally purged, but my Bypass Cache page rule isn’t happening (yet). New purges aren’t happening, either. At this point, I’ll wait until it works itself out.

Well the cache purge issue is still not solved for me, so I think I will open a ticket with support.

What about you @sdayman, are you able to purge the cache on your end?

No, but they’re still working on it. Until that issue shows up as Resolved, I’ll leave them alone.


Seems like the cache is now purging much faster.

I will mark this issue as resolved.

A big thanks to everyone for your help.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.