Purge Everything results in page stripped off all styles and scripts

wordpress
cache
#1

Just hit Purge Everything on my cache. After I did it, I got a white screen with all the content, but no styling or scripts are loading. So I went into Terminal, cleared my DNS cache and still… no difference.

It’s a WordPress site and what’s interesting is when I’m logged in I can see my site precisely as I should. Log out and it’s this white mess. It’s not even the right theme! I can tell because the logo is different.

Anyone know of a way to make this actually work?
https://www.hellodadventures.com/

0 Likes

#2

I’m seeing 404’s in the Dev Tools for
https://www.hellodadventures.com/wp-content/cache/swift-performance/www.hellodadventures.com/css/ddc3891a97dbf7950074bcee464bffd2.css

0 Likes

#3

I noticed this which is unusual, in console: Loading failed for the <script> with source “https://www.hellodadventures.com/wp-content/cache/swift-performance/www.hellodadventures.com/js/b32f94f54047b52d607ab7627fef724d.js”.

That can’t be the correct path. Can it?

0 Likes

#4

I’m not familiar with that plugin but it does look unusual. Is it a regular WP installation or Multisite?

0 Likes

#5

Regular.

And I just turned off all the minification on Swift Performance Lite, Purged in CF again (just the homepage) and still seeing three 404’s for minified files.

0 Likes

#6

Maybe temporarily disable the plugin completely or reset it and/or take a look here https://swiftperformance.io/kb/strange-redirects/
But honestly, I think you should connecting with them directly.

0 Likes

#7

I did that, Purged in CF again, and still getting the same page with the same errors, even in an incognito window. How is that even possible?

0 Likes

#8

If disabling the plugin & purging didn’t fix it for regular visitors, but does work after logging in, disabling doesn’t modify modify htaccess. I’d still contact them.

0 Likes

#9

Actually, I figured it out. Turns out I didn’t purge cache everywhere. There was still one more spot. In cPanel. There’s a Cache Manager there too and that was not purged. And since it’s NGINX, it had to be. So I purged that and got the site back. Then I re-activated Swift and brought CF back out of development mode. All good now or so it seems. Still, THREE places?! They sure don’t make it easy!

1 Like

#10

I see you are using Inmotion hosting, Page cache.



HeadersResponse
https://www.hellodadventures.com/
Response Version
HTTP/2.0
Response Headers
set-cookie	
__cfduid=d3313bbf379411c11e12e1b1db50a839a1554461295; expires=Sat, 04-Apr-20 10:48:15 GMT; path=/; domain=.hellodadventures.com; HttpOnly; Secure
cache-control	
max-age=0
last-modified	
Fri, 05 Apr 2019 09:58:56 GMT
status	
200
date	
Fri, 05 Apr 2019 10:48:15 GMT
vary	
Accept-Encoding
content-encoding	
br
cf-ray	
4c2af2d8a98cc7c3-DEN
expect-ct	
max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
content-type	
text/html
x-proxy-cache	
HIT
server	
cloudflare
expires	
Fri, 05 Apr 2019 10:48:10 GMT

What this indicates me, your minify plugin and inbuilt proxy cache may not be purging at the right event like when you purge swift cache.

Are you using Varnish or something like Super cache? Configure it properly.

Solution: Purge hosting end Page cache.

0 Likes